Version 1 (modified by gustavolepri, 8 anos atrás) (diff)

--

Instalação do SAPL versão 2.4

INTRODUÇÃO

Este roteiro destina-se a instalação do SAPL em um novo ambiente. Assim, caso o ambiente já contenha um SAPL, consulte o roteiro de migração 23-24.

Todo o processo de instalação deve ser feito por meio de linha de comando usando o Terminal. Caso você não esteja familiarizado com o Sistema Operacional Linux (Ubuntu), e deseja instalar o SAPL versão 2.4 em um computador com uma interface gráfica (Ubuntu-Desktop), localize no menu Aplicativos>Acessórios o utilitário Terminal, ou utilize o atalho Control+Alt+T .

O processo de instalação do SAPL versão 2.4 foi testado apenas na distribuição Ubuntu 11.04. Para melhor compreensão do usuário, o processo citado foi dividido em duas fases, descritas no sumário.


SUMÁRIO

FASE 1 - PREPARAÇÃO DO AMBIENTE - Instalação e configuração de todos os softwares e bibliotecas de apoio necessários para o pleno e correto funcionamento do Sapl versão 2.4.

FASE 2 - INSTALAÇÃO DO SAPL 2.4 NO SERVIDOR - Execução de um script que realiza todas as tarefas necessárias à instalação do Sapl versão 2.4, no sistema de arquivos de seu servidor.


FASE 1 - PREPARAÇÃO DO AMBIENTE

1) Instalação do SGBD MySQL: Execução de um script que realiza todas as tarefas necessárias à instalação do Sapl versão 2.4, no sistema de arquivos de seu servidor.

$ sudo apt-get install mysql-server

Siga os passos abaixo informando os dados necessários para a finalização da instalação do MySQL.

2) Instalação da biblioteca de desenvolvimento libmysqlclient-dev: Necessária para compilar o python-mysql, usado pelo conector ZMySQLDA.

$ sudo apt-get install libmysqlclient-dev

3) Instalação do utilitário Subversion: Gerenciador de versões de software.

$ sudo apt-get install subversion

4) Instalação do pacote de utilitários build-essential: Pacote que contém diversos utilitários (make, gcc e g++) necessários para a transformação do código fonte em código de máquina.

$ sudo apt-get install build-essential

5) Instalação biblioteca de desenvolvimento libreadline: Responsável por gerenciar o histórico de linha de comando do Python.

$ sudo apt-get install libreadline6 libreadline6-dev readline-common

6) Instalação biblioteca de compactação zlib: Responsável por ativar suporte à compressão e à descompressão de arquivos no Python e Zope

$ sudo apt-get install zlib1g-dev

7) Baixar o instalador Sapl versão 2.4 do repositório Interlegis: Utilizando o Subversion será feito checkout de todos os arquivos necessários para a instalação do Sapl versão 2.4:

 $ sudo svn co http://repositorio.interlegis.gov.br/ILSAPL/install/2.4-beta/ install_sapl

8) Leitura de instruções gerais: Criou-se o diretório install_sapl dentro da pasta em que foi executado o comando do PASSO 6. Leia as instruções completas da instalação. É importante que todos os pré-requisitos estejam instalados corretamente.

$ less install_sapl/LEIAME.txt

FASE 2 - INSTALAÇÃO DO SAPL 2.4 NO SERVIDOR

8) Execução do Script de Instalação do Sapl versão 2.4: O Processo de instalação é automatizado. Após executar o comando abaixo, será necessário apenas informar o nome do usuário ('root') e senha do Mysql(criado no PASSO 1).

$ cd install_sapl
$ sudo bash install.sh 

9) Arquivo de senha: Ao final da instalação, conheça a senha do usuário admin que é o administrador do Zope, bem como os comandos de inicialização (start) e de finalização (shutdown) do SAPL, por meio do comando abaixo:

$ sudo less /var/interlegis/SAPL-2.4-beta/adminPassword.txt

Observação: O processo de instalação faz a verificação dos pacotes necessários. Em caso de erro, confira a lista dos pré-requisitos refazendo as instalações e, em seguida, repita o passo 8. Aguarde a mensagem "Instalando sapl..."

10) Teste de funcionamento do sistema: Abra um navegador web e digite na barra de endereços: http://127.0.0.1:8080/sapl. O endereço citado é o IP da máquina local. Para acessar outro servidor, utilize http://<ip_do_servidor>:8080/sapl.

Pronto! SAPL instalado com sucesso!


Qualquer problema durante o processo de atualização, reporte à Comunidade GITEC e abra um ticket aqui: registro de problemas.

 

The contents and data of this website are published under license:
Creative Commons 4.0 Brasil - Atribuir Fonte - Compartilhar Igual.