Como Preparar o Eclipse Para o Sigi

Faça o download do eclipse a partir do site oficial. Procure pela versão 3.6.1 ou superior. Usamos nesse tutorial a versão 3.6.1, então todos os exemplos se referem a essa versão.

Obs: Todos os procedimentos aqui pressuõem poderes de supercow superusuário, o que é denotado pela marca # no início das linhas de comando. Você deverá então preceder os comandos com sudo, ou então executar um sudo su para alternar para root.

Procedimentos para instalação do eclipse

  • Descompactar o arquivo na pasta /opt:
    # cd /opt
    # tar zxvf eclipse-SDK-3.6.1-linux-gtk.tar.gz
    
  • Criar os links para execução do eclipse:
    # ln -s /opt/eclipse/eclipse /etc/alternatives/eclipse
    # ln -s /etc/alternatives/eclipse /usr/bin/eclipse
    
  • Executar o eclipse, para poder instalar os plugins a partir da interface gráfica:
    # eclipse
    
  • Instalar pacotes:
    • Help -> Install New Software
    • No campo Work with, selecione Helios - http://download.eclipse.org/releases/helios. Se a fonte de pacotes Helios não aparecer na lista, você terá que criá-la, seguindo os passos:
      • Clicar em Add...
      • Em Name, escreva Helios - http://download.eclipse.org/releases/helios
      • Em Location, escreva http://download.eclipse.org/releases/helios
      • Clicar em Ok
    • Quando a lista de pacotes aparecer, selecione os seguintes:
      • Business Inteligence, Reporting and Charting:
        • BIRT Framework
        • Eclipse BIRT Chart Context Sensitive Help Documentation
        • Eclipse BIRT Context Sensitive Help Documentation
        • Eclipse BIRT Documentation
        • Eclipse BIRT Example
      • Collaboration
        • Subversive SVN Team Provider (Incubation)
        • Subversive Revision Graph (Optional) (Incubation)
      • Database Development
        • Selecionar todos!
      • General Purpose Tools
        • Local Terminal (Incubation)
      • SOA Development
        • BPMN Project Feature
      • Web, XML, and Java EE Development
        • Eclipse Web Developer Tools
        • Eclipse XML Editors and Tools
        • Eclipse XSL Developer Tools
        • JavaScript Development Tools
        • Web Page Editor (Optional)

Instale esses pacotes (clicando em next, next, finish). Se ocorrer algum erro, tente novamente. Se o problema persistir, apague a pasta /opt/eclipse e comece do início. Tente também instalar aos poucos.

  • Instale o Pydev:
    • Selecione Help -> Install new software, clique no botão Add...
    • Preencha Name com Pydev org e Location com http://pydev.org/updates.
    • Clique Ok.
    • Selecione e instale o pacote PyDev > PyDev for Eclipse

Caso encontre problemas na instalação do Pydev, pode-se baixar o .zip e descompactá-lo diretamente na pasta /opt/eclipse/plugins. Deve-se verificar as permissões e o owner dos arquivos para que funcione.

  • Colocar o eclipse em português do Brasil:

Acessar a página do Eclipse Babel Project (http://www.eclipse.org/babel/) e vá para a área de downloads. Baixar os pacotes de linguagem (pt_BR) para cada pacote de software instalado no item anterior (alguns não existem, mas baixe o que tiver).

Quando escrevi este documento, os pacotes que encontrei foram os seguintes:

  • BabelLanguagePack-birt-pt_BR_3.6.0.v20101211043401.zip
  • BabelLanguagePack-datatools-pt_BR_3.6.0.v20101211043401.zip
  • BabelLanguagePack-eclipse-pt_BR_3.6.0.v20101211043401.zip
  • BabelLanguagePack-technology.linux-distros-pt_BR_3.6.0.v20101211043401.zip
  • BabelLanguagePack-webtools.common-pt_BR_3.6.0.v20101211043401.zip
  • BabelLanguagePack-webtools.sourceediting-pt_BR_3.6.0.v20101211043401.zip
  • BabelLanguagePack-webtools.webservices-pt_BR_3.6.0.v20101211043401.zip

Depois de baixar, descompacte todos os arquivos na pasta /opt/eclipse. Pronto! Seu eclipse agora está traduzido para o português!

Última modificação 6 anos atrás Última modificação em 04/05/2011 19:42:01
 

The contents and data of this website are published under license:
Creative Commons 4.0 Brasil - Atribuir Fonte - Compartilhar Igual.