SAAP 2.0

Documentação do Sistema de Apoio à Atividade Parlamentar versão 2.0.

Instalação do Sistema

A versão 2.0 do SAAP pode ser instalada de duas formas:

Em qualquer sistema Unix/Linux?

Antes de instalar o SAAP é aconselhável que seja feita a instalação das seguintes bibliotecas do sistema operacional:

  • zlib
  • libjpeg
  • libssl
  • readline
  • libxml2
  • libxslt
  • freetype
  • wv
  • xpdf

Se estiver instalando no Ubuntu/Debian?, provavelmente, o comando abaixo instalará todas:

$ sudo apt-get install zlib1g-dev libjpeg62-dev libssl-dev libreadline5-dev readline-common libxml2-dev libxslt1-dev libfreetype6-dev wv xpdf build-essential

1) Faça download do pacote de instalação ou execute o comando:

$ svn export http://repositorio.interlegis.gov.br/ILSAAP/install/2.0 SAAP-2.0

2) Entre no diretório de instalação e execute o instalador:

$ cd SAAP-2.0
$ sudo ./install.sh

OBSERVAÇÃO IMPORTANTE: Se você tinha o SAAP beta previamente instalado, é necessário remover o link simbólico do pisa antes de executar o instalador. Para efetuar essa remoção, execute o seguinte comando:

$ sudo rm /usr/bin/pisa

3) O SAAP será instalado no diretório /var/interlegis/SAAP-2.0. No diretório 'instance' estará a instância Zope e o respectivo script (em bin/zopectl) para inicialização, reinicialização, parar, etc. Você pode linkar esse script no rc.init do seu sistema operacional. Para inicializar o Zope execute o comando:

$ sudo /var/interlegis/SAAP-2.0/instance/bin/zopectl start

Em sistemas Ubuntu LTS ou Debian (ainda não está funcionando...)

1) Adicione a seguinte linha no final do arquivo /etc/apt/sources.list do seu servidor:

  • Se for Ubuntu 6.06:
deb http://arquivos.interlegis.leg.br/repositorio dapper main
  • Se for Ubuntu 8.04:
deb http://arquivos.interlegis.leg.br/repositorio hardy main
  • Se for Debian:
deb http://arquivos.interlegis.leg.br/repositorio etch main

2) Como o repositório é assinado eletronicamente, deve-se adicionar a chave do repositório ao chaveiro do APT, para isso execute o comando:

$ wget http://arquivos.interlegis.leg.br/repositorio/interlegis.asc -O - | sudo apt-key add -

3) Atualize a lista de pacotes e instale o SAAP:

$ sudo apt-get update
$ sudo apt-get install saap2.0

Em outros sistemas operacionais

O SAAP não possui suporte do Interlegis para a instalação em plataformas não-UNIX, como por exemplo o MS Windows. Apesar disso, por ter sido baseado em Python/Zope/Plone?, que é multiplataforma, é possível essa instalação a partir dos fontes desses sistemas, obtidos a partir do pacote de instalação.

Outra possibilidade é utilizar uma MaquinaVirtual com os sistemas instalados.

Reportar Bugs/Sugestões?

Para sugerir melhorias ou reportar problemas com o SAAP 2.0, clique no link abaixo e preencha o formulário para abrir uma nova solicitação no sistema de tickets do Colab:

Documentação e Relatórios do SAAP 2.0

A documentação completa do SAAP está disponível em ProjetoSaap e a documentação da versão 2.0 é a seguinte:

Fase 1

Fase 2

Outros

Veja também, como configurar do SAAP 2.0 após a instalação.

Fase 3

Última modificação 5 anos atrás Última modificação em 13/02/2015 19:55:34
 

The contents and data of this website are published under license:
Creative Commons 4.0 Brasil - Atribuir Fonte - Compartilhar Igual.